故障排除

故障排除

本节将为您提供在 ServiceDesk Plus 清单模块中扫描工作站时遇到的问题的解决方案(按顺序)。

  1. 该用户的访问权限被拒绝,或者工作站中的远程 DCOM 选项被禁用。

  2. 用户没有执行此操作的访问权限。

  3. 服务器机器中的远程 DCOM 选项已禁用。

  4. 与工作站中 RPC 服务器的连接失败。

  5. 其中一个 WMI 组件未正确注册。

  6. 工作站的 WMI 服务执行失败。

  7. 工作站的 WMI 服务已禁用。

  8. 工作站拒绝扫描操作请求。

  9. 与工作站 Telnet 服务的连接失败。

  10. 工作站中的用户名或密码不正确。

  11. 扫描操作超时。

  12. 当前平台不支持调用的操作。

  13. 执行操作时出现一般故障。

错误信息

要么拒绝用户访问,要么在工作站中禁用了远程 DCOM 选项

原因

由于以下原因导致 Windows 工作站扫描失败时,会显示此错误消息:

  1. 工作站中为扫描提供的登录名和密码可能无效。

  2. 远程工作站中的远程 DCOM 选项可能被禁用。

解决方案

  1. 检查登录名和密码是否输入正确。

  2. 检查远程工作站是否启用了远程 DCOM。 如果未启用,则启用。



    在 Windows 2000 计算机中启用 DCOM:

    1. 选择开始 > 运行

    2. 在文本字段中输入 DCOMCNFG

    3. 单击 "确定"。

    4. 选择 "默认属性 "选项卡

    5. 选中 "在本机启用分布式 COM "复选框

    6. 点击确定

    在 Windows XP 计算机中启用 DCOM:
    1. 选择开始 > 运行

    2. 在文本字段中输入 DCOMCNFG

    3. 点击确定

    4. 右键单击组件服务 > 计算机 > 我的电脑

    5. 单击属性

    6. 在弹出的框架中选择 "默认属性 "选项卡

    7. 选中 "在本机启用分布式 COM "复选框

    8. 按确定

  3. 检查用户账户在目标工作站中是否有效。 为此,在(服务器计算机的)命令提示符下执行以下命令。



    net use \\<RemoteComputerName>\C$  /u:<DomainName\UserName>  "<password>"

    net use \\<RemoteComputerName>\ADMIN$  /u:<DomainName\UserName>  "<password>"



    替换 <> 中的相关值。 在引号内输入密码。

如果这些命令显示任何错误信息,则说明所提供的用户账户在该远程计算机中无效。

 

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错误信息

用户没有执行此操作的访问权限

原因

如果为扫描提供的用户 ID 没有足够的访问权限来执行扫描操作,则会显示此类错误信息。 该用户可能不属于工作站的管理员组。

解决方案

将用户移动到工作站的管理员组(或),用管理员(最好是域管理员)账户扫描。

 

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错误信息

服务器机器中的远程 DCOM 选项已禁用

原因

运行 ServiceDesk Plus Server 的计算机可能禁用了远程 DCOM 选项。

解决方案

ServiceDesk 使用 Windows 管理工具 (WMI) 扫描远程工作站。 WMI 通过远程 DCOM 工作,因此必须启用该选项才能扫描远程机器。

 

要了解如何在 Windows 系统中启用 DCOM,请参阅错误信息的解决方法 要么拒绝用户访问,要么在工作站中禁用了远程 DCOM 选项

 

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错误信息与工作站中 RPC 服务器的连接失败

原因

如果远程计算机上配置了防火墙,则会显示此信息。 这种例外情况大多发生在 Windows XP (SP-2) 中,即默认的 Windows 防火墙已启用。

解决方案

禁用工作站的默认防火墙。 在 Windows XP (SP2) 中禁用防火墙
  1. 选择开始->运行

  2. 键入 Firewall.cpl

  3. 点击确认。

  4. 在常规选项卡中,单击关闭。

  5. 点击确认。

如果无法禁用防火墙,我们可以为远程计算机上的管理员启动远程管理功能。 在目标计算机上执行以下命令即可启用该功能:

 

netsh friewall set service RemoteAdmin

 

扫描计算机后,如果需要,还可以禁用远程管理功能。 以下命令可禁用该功能:

 

netsh friewall set service RemoteAdmin disable

 

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错误信息其中一个 WMI 组件未正确注册

原因

如果 WMI 在远程 Windows 工作站中不可用,则会显示此消息。 在 Windows 9x、Windows NT 和 Windows ME 中都会出现这种情况。 如果 WMI 组件未正确注册,在更高版本的 Windows 中也可能出现此类错误代码。

解决方案

在远程工作站中安装 WMI core。 可从微软网站下载。 如果问题是由于 WMI 组件注册造成的,那么请在命令提示符下执行以下命令来注册 WMI dlls:



winmgmt /RegServer

 

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错误信息工作站 WMI 服务执行失败

原因

当远程工作站中运行的 WMI 服务(winmgmt.exe)出现内部执行故障时,就会显示此类错误信息。 可能是该工作站中 WMI 资源库的最后一次更新失败。

解决方案

在远程工作站中重启 WMI 服务。 要在工作站中重启 WMI 服务

  1. 单击开始 -> 运行。

  2. 输入Services.msc

  3. 点击确认。

  4. 在弹出的 "服务 "窗口中,选择 "Windows Management Instrumentation "服务并右键单击。

  5. 单击重新启动。

 

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错误信息工作站中的 WMI 服务已禁用

原因

如果远程工作站未启用 WMI 服务 (winmgmt.exe),则会显示此错误信息。

解决方案

将 WMI 服务属性从禁用修改为手动或自动。

  1. 单击开始 -> 运行。

  2. 键入 Services.msc

  3. 点击确认。

  4. 在弹出的 "服务 "窗口中,选择 "Windows Management Instrumentation "服务并右键单击。

  5. 单击属性。

  6. 如果启动类型为 "禁用",请将其变更为 "自动/手动 "并启动服务。

  7. 重新启动服务。

 

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错误信息工作站拒绝扫描操作请求

原因

目标工作站注册表中的 DCOM 设置拒绝扫描请求。

解决方案

如下所述,编辑注册表key值:
  1. 使用 Regedit 浏览到 HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\OLE.

  2. 双击 EnableDCOM 值名称(字符串 (REG_SZ) 数据类型)。 将其数据值设置为 "Y",即使已经设置为 "Y"。

  3. 点击确认。

  4. 关闭并重新启动计算机。

 

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错误信息与工作站 Telnet 服务的连接失败

原因

目标计算机中可能未运行 Telnet 服务(或)Telnet 服务未在默认端口 23 中运行。

解决方案

ServiceDesk 通过 Telnet 发现远程 Linux 机器。 确保远程工作站运行的 Telnet 默认端口为 23。

 

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错误信息工作站中的用户名或密码不正确

原因

为扫描远程工作站提供的用户名和密码不正确。

解决方案

在 ServiceDesk Plus 中,使用 Telnet 可以发现 Linux 工作站。 提供能与目标工作站成功建立远程登录会话的有效用户名和密码。

 

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错误信息扫描操作超时

原因

目标工作站未在默认时限内响应。 这可能是由于网络延迟造成的。

解决方案

稍后尝试扫描工作站。 如果重复出现相同的错误信息,请通过 servicedeskplus-support@manageengine.com 联系 ServiceDesk Plus 支持团队。

 

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错误信息当前平台不支持调用的操作

原因

如果工作站的操作系统不是 Windows 或 Linux,则会显示此类错误代码。

解决方案

目前,ServiceDesk Plus 中的网络发现功能仅支持 Windows 或 Linux 机器。

 

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错误信息执行操作时出现一般故障

原因

扫描工作站时出现了一些意外异常。

解决方案

请通过support@manageengine.cn与服务台支持团队联系,并提供错误日志文件。 您可以单击 ServiceDesk Plus 应用程序中的支持文件链接,从支持选项卡中获取错误日志文件。

 

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